about summary refs log tree commit diff
path: root/configurations/eonwe/default.nix
diff options
context:
space:
mode:
authorazahi <azat@bahawi.net>2025-02-17 02:21:56 +0300
committerazahi <azat@bahawi.net>2025-02-17 02:21:56 +0300
commit59180328cda59817d71cd58c8f48ead047375064 (patch)
tree2cdd7d1bfa309839ef624c19daf283f510aacf69 /configurations/eonwe/default.nix
parent2025-02-05 (diff)
2025-02-17
Diffstat (limited to '')
-rw-r--r--configurations/eonwe/default.nix25
1 files changed, 12 insertions, 13 deletions
diff --git a/configurations/eonwe/default.nix b/configurations/eonwe/default.nix
index a5cf7e9..d6bc46c 100644
--- a/configurations/eonwe/default.nix
+++ b/configurations/eonwe/default.nix
@@ -4,15 +4,14 @@
   pkgs,
   ...
 }:
-with lib;
 {
-  imports = attrValues (modulesIn ./.);
+  imports = lib.modulesIn ./. |> lib.attrValues;
 
   nixfiles.modules = {
     ark.enable = true;
 
     wireguard.client.enable = true;
-    wireguard-ng.client.enable = false;
+    # wireguard-ng.client.enable = false;
 
     syncthing.enable = true;
 
@@ -42,12 +41,12 @@ with lib;
     ];
 
     programs = {
-      beets.settings.directory = mkForce "/mnt/udata/music";
+      beets.settings.directory = lib.mkForce "/mnt/udata/music";
 
       mpv = {
         profiles =
           let
-            mapShaders = map (args: toString (pkgs.fetchurl args));
+            mapShaders = map (x: x |> pkgs.fetchurl |> toString);
             cfl-prediction = mapShaders [
               {
                 url = "https://raw.githubusercontent.com/Artoriuz/glsl-chroma-from-luma-prediction/9fdd0bc68cd8ae42a8072a7d5d098f118daa4293/CfL_Prediction.glsl";
@@ -105,7 +104,7 @@ with lib;
           vf = "format=colorlevels=full:colormatrix=auto";
           video-output-levels = "full";
 
-          glsl-shaders-append = map (text: toString (pkgs.writeText "shader.hook" text)) [
+          glsl-shaders-append = map (x: x |> pkgs.writeText "shader.hook" |> toString) [
             ''
               //!HOOK LUMA
               //!BIND HOOKED
@@ -143,7 +142,7 @@ with lib;
     };
 
     services = {
-      mpd.musicDirectory = mkForce "/mnt/udata/music";
+      mpd.musicDirectory = lib.mkForce "/mnt/udata/music";
 
       xsettingsd.settings."Xft/DPI" = "93";
     };
@@ -161,17 +160,17 @@ with lib;
       enable = true;
       notifications.mail = {
         enable = true;
-        sender = "smartd@${my.domain.shire}";
-        recipient = "smartd@${my.domain.shire}";
+        sender = "root@${lib.my.domain.shire}";
+        recipient = "root@${lib.my.domain.shire}";
       };
     };
 
     openssh.settings = {
-      KbdInteractiveAuthentication = mkForce true;
-      PasswordAuthentication = mkForce true;
+      KbdInteractiveAuthentication = lib.mkForce true;
+      PasswordAuthentication = lib.mkForce true;
     };
 
-    udev.packages = with pkgs; [ vial ];
+    udev.packages = [ pkgs.vial ];
 
     xserver.wacom.enable = true;
   };
@@ -264,7 +263,7 @@ with lib;
     # [1]: https://github.com/ryantm/agenix/issues/45#issuecomment-847852593
     # [1]: https://github.com/nix-community/impermanence/issues/22
     # [1]: https://github.com/NixOS/nixpkgs/pull/86967#pullrequestreview-667929259
-    "/home/${my.username}".neededForBoot = true;
+    "/home/${lib.my.username}".neededForBoot = true;
 
     "/mnt/ydata/music" = {
       device = "yavanna.shire.net:/export/music";

Consider giving Nix/NixOS a try! <3