about summary refs log tree commit diff
path: root/configurations/test-headless/default.nix
diff options
context:
space:
mode:
authorAzat Bahawi <azat@bahawi.net>2022-08-12 22:53:53 +0300
committerAzat Bahawi <azat@bahawi.net>2022-08-12 22:53:53 +0300
commit61b94f0dd06cac0f7dcd38cce80f2a7ab8376098 (patch)
treeb703a9fe11eae6c4cae4e4682f02caf0caa171d0 /configurations/test-headless/default.nix
2022-08-12
Diffstat (limited to '')
-rw-r--r--configurations/test-headless/default.nix22
1 files changed, 22 insertions, 0 deletions
diff --git a/configurations/test-headless/default.nix b/configurations/test-headless/default.nix
new file mode 100644
index 0000000..c085e63
--- /dev/null
+++ b/configurations/test-headless/default.nix
@@ -0,0 +1,22 @@
+{
+  lib,
+  modulesPath,
+  ...
+}:
+with lib; {
+  imports = ["${modulesPath}/profiles/qemu-guest.nix"];
+
+  # This will allow `nix flake check` tests to pass.
+  nixfiles.modules = {
+    endlessh-go.enable = mkForce false;
+    node-exporter.enable = mkForce false;
+    promtail.enable = mkForce false;
+  };
+
+  boot.loader.systemd-boot.enable = true;
+  fileSystems."/".device = "/dev/null";
+
+  documentation.enable = mkForce false;
+
+  system.stateVersion = "22.05";
+}

Consider giving Nix/NixOS a try! <3