about summary refs log tree commit diff
path: root/flake.nix
diff options
context:
space:
mode:
authorAzat Bahawi <azat@bahawi.net>2022-11-10 14:19:19 +0300
committerAzat Bahawi <azat@bahawi.net>2022-11-10 14:19:19 +0300
commit164b2b3f693dd5da3c1b1661e43c45b36a6b764c (patch)
tree2fc9a4ab1d3b44a3eb6d686b42527a18411c240b /flake.nix
parent2022-10-26 (diff)
2022-11-10
Diffstat (limited to '')
-rw-r--r--flake.nix84
1 files changed, 47 insertions, 37 deletions
diff --git a/flake.nix b/flake.nix
index f5b1a48..39cd74a 100644
--- a/flake.nix
+++ b/flake.nix
@@ -84,33 +84,43 @@
       ref = "master";
       inputs = {
         emacs-overlay.follows = "emacs-overlay";
-        flake-compat.follows = "flake-compat";
         flake-utils.follows = "flake-utils";
         nixpkgs.follows = "nixpkgs";
       };
     };
 
-    nix-minecraft-servers = {
-      type = "github";
-      owner = "jyooru";
-      repo = "nix-minecraft-servers";
-      ref = "main";
-      inputs = {
-        nixpkgs.follows = "nixpkgs";
-        utils.follows = "flake-utils-plus";
-      };
-    };
+    # nil = {
+    #   type = "github";
+    #   owner = "oxalica";
+    #   repo = "nil";
+    #   ref = "main";
+    #   inputs = {
+    #     flake-utils.follows = "flake-utils";
+    #     nixpkgs.follows = "nixpkgs";
+    #   };
+    # };
 
-    pollymc = {
-      type = "github";
-      owner = "fn2006";
-      repo = "PollyMC";
-      ref = "1.4.2";
-      inputs = {
-        flake-compat.follows = "flake-compat";
-        nixpkgs.follows = "nixpkgs";
-      };
-    };
+    # nix-minecraft-servers = {
+    #   type = "github";
+    #   owner = "jyooru";
+    #   repo = "nix-minecraft-servers";
+    #   ref = "main";
+    #   inputs = {
+    #     nixpkgs.follows = "nixpkgs";
+    #     utils.inputs.flake-utils.follows = "flake-utils";
+    #   };
+    # };
+
+    # pollymc = {
+    #   type = "github";
+    #   owner = "fn2006";
+    #   repo = "PollyMC";
+    #   ref = "5.1";
+    #   inputs = {
+    #     flake-compat.follows = "flake-compat";
+    #     nixpkgs.follows = "nixpkgs";
+    #   };
+    # };
 
     dns-nix = {
       type = "github";
@@ -210,25 +220,25 @@
       flake = false;
     };
 
-    # NOTE These inputs are used indirectly by other inputs. These are declared
-    # explicitly because nested follows are broken[1].
+    # NOTE These inputs are used indirectly. They are declared explicitly here
+    # because nested follows is not yet release in a stable version of nix[1].
     #
     # [1]: https://github.com/NixOS/nix/issues/5790
     # [1]: https://github.com/NixOS/nix/pull/6621
-    flake-utils-plus = {
-      type = "github";
-      owner = "gytis-ivaskevicius";
-      repo = "flake-utils-plus";
-      ref = "master";
-      inputs.flake-utils.follows = "flake-utils";
-    };
-    flake-compat = {
-      type = "github";
-      owner = "edolstra";
-      repo = "flake-compat";
-      ref = "master";
-      flake = false;
-    };
+    # flake-utils-plus = {
+    #   type = "github";
+    #   owner = "gytis-ivaskevicius";
+    #   repo = "flake-utils-plus";
+    #   ref = "master";
+    #   inputs.flake-utils.follows = "flake-utils";
+    # };
+    # flake-compat = {
+    #   type = "github";
+    #   owner = "edolstra";
+    #   repo = "flake-compat";
+    #   ref = "master";
+    #   flake = false;
+    # };
   };
 
   outputs = inputs:

Consider giving Nix/NixOS a try! <3