about summary refs log tree commit diff
path: root/flake.nix
diff options
context:
space:
mode:
authorAzat Bahawi <azat@bahawi.net>2022-09-14 12:08:10 +0300
committerAzat Bahawi <azat@bahawi.net>2022-09-14 12:08:10 +0300
commit6a02d658dde1fd5e9d9e84478796b6881b236578 (patch)
tree02b5e0372998ca089b22e2d78bfa499b736ee13e /flake.nix
parent2022-09-13 (diff)
2022-09-14
Diffstat (limited to '')
-rw-r--r--flake.nix48
1 files changed, 33 insertions, 15 deletions
diff --git a/flake.nix b/flake.nix
index 6d38577..5fd0fb5 100644
--- a/flake.nix
+++ b/flake.nix
@@ -83,8 +83,9 @@
       repo = "nix-doom-emacs";
       ref = "master";
       inputs = {
-        flake-utils.follows = "flake-utils";
         emacs-overlay.follows = "emacs-overlay";
+        flake-compat.follows = "flake-compat";
+        flake-utils.follows = "flake-utils";
         nixpkgs.follows = "nixpkgs";
       };
     };
@@ -100,6 +101,17 @@
       };
     };
 
+    pollymc = {
+      type = "github";
+      owner = "fn2006";
+      repo = "PollyMC";
+      ref = "1.4.2";
+      inputs = {
+        flake-compat.follows = "flake-compat";
+        nixpkgs.follows = "nixpkgs";
+      };
+    };
+
     dns-nix = {
       type = "github";
       owner = "kirelagin";
@@ -140,19 +152,6 @@
       ref = "master";
     };
 
-    # NOTE Used indirectly by nix-minecraft-servers.
-    # This is declared explicitly because nested follows are broken[1].
-    #
-    # [1]: https://github.com/NixOS/nix/issues/5790
-    # [1]: https://github.com/NixOS/nix/pull/6621
-    flake-utils-plus = {
-      type = "github";
-      owner = "gytis-ivaskevicius";
-      repo = "flake-utils-plus";
-      ref = "master";
-      inputs.flake-utils.follows = "flake-utils";
-    };
-
     flake-registry = {
       type = "github";
       owner = "NixOS";
@@ -216,6 +215,26 @@
       ref = "master";
       flake = false;
     };
+
+    # NOTE These inputs are used indirectly by other inputs. These are declared
+    # explicitly because nested follows are broken[1].
+    #
+    # [1]: https://github.com/NixOS/nix/issues/5790
+    # [1]: https://github.com/NixOS/nix/pull/6621
+    flake-utils-plus = {
+      type = "github";
+      owner = "gytis-ivaskevicius";
+      repo = "flake-utils-plus";
+      ref = "master";
+      inputs.flake-utils.follows = "flake-utils";
+    };
+    flake-compat = {
+      type = "github";
+      owner = "edolstra";
+      repo = "flake-compat";
+      ref = "master";
+      flake = false;
+    };
   };
 
   outputs = inputs:
@@ -268,7 +287,6 @@
 
         # TODO Make it so that self.packages also can use this.
         overlays.default = final: _: {
-          UltimMC = final.libsForQt5.callPackage ./packages/ultimmc.nix {};
           bruh = final.callPackage ./packages/bruh.nix {};
           mpv-autosub = final.callPackage ./packages/mpv-autosub.nix {};
           myip = final.callPackage ./packages/myip.nix {};

Consider giving Nix/NixOS a try! <3