about summary refs log tree commit diff
path: root/flake.nix
diff options
context:
space:
mode:
authorAzat Bahawi <azat@bahawi.net>2022-12-17 16:39:09 +0300
committerAzat Bahawi <azat@bahawi.net>2022-12-17 16:39:09 +0300
commit8f137c28230623259a964484adcf31fe00756594 (patch)
tree82bce6a13fda125087cf6d9dc80aa91d9230d6c4 /flake.nix
parent2022-11-20 (diff)
2022-12-17
Diffstat (limited to '')
-rw-r--r--flake.nix50
1 files changed, 27 insertions, 23 deletions
diff --git a/flake.nix b/flake.nix
index 7fcd818..46d1252 100644
--- a/flake.nix
+++ b/flake.nix
@@ -24,7 +24,7 @@
       type = "github";
       owner = "NixOS";
       repo = "nixpkgs";
-      ref = "release-22.05";
+      ref = "release-22.11";
     };
 
     # For testing PRs and stuff.
@@ -47,6 +47,14 @@
       ref = "master";
     };
 
+    darwin = {
+      type = "github";
+      owner = "LnL7";
+      repo = "nix-darwin";
+      ref = "master";
+      inputs.nixpkgs.follows = "nixpkgs";
+    };
+
     home-manager = {
       type = "github";
       owner = "nix-community";
@@ -83,6 +91,7 @@
       repo = "nix-doom-emacs";
       ref = "master";
       inputs = {
+        flake-compat.follows = "flake-compat";
         emacs-overlay.follows = "emacs-overlay";
         flake-utils.follows = "flake-utils";
         nixpkgs.follows = "nixpkgs";
@@ -184,8 +193,10 @@
       repo = "pre-commit-hooks.nix";
       ref = "master";
       inputs = {
+        flake-compat.follows = "flake-compat";
         flake-utils.follows = "flake-utils";
         nixpkgs.follows = "nixpkgs";
+        nixpkgs-stable.follows = "nixpkgs-stable";
       };
     };
 
@@ -220,32 +231,20 @@
       flake = false;
     };
 
-    # NOTE These inputs are used indirectly. They are declared explicitly here
-    # because nested follows is not yet release in a stable version of nix[1].
-    #
-    # [1]: https://github.com/NixOS/nix/issues/5790
-    # [1]: https://github.com/NixOS/nix/pull/6621
-    # flake-utils-plus = {
-    #   type = "github";
-    #   owner = "gytis-ivaskevicius";
-    #   repo = "flake-utils-plus";
-    #   ref = "master";
-    #   inputs.flake-utils.follows = "flake-utils";
-    # };
-    # flake-compat = {
-    #   type = "github";
-    #   owner = "edolstra";
-    #   repo = "flake-compat";
-    #   ref = "master";
-    #   flake = false;
-    # };
+    flake-compat = {
+      type = "github";
+      owner = "edolstra";
+      repo = "flake-compat";
+      ref = "master";
+      flake = false;
+    };
   };
 
   outputs = inputs:
     with inputs; let
       lib = nixpkgs.lib.extend (import ./lib);
     in
-      flake-utils.lib.eachSystem ["x86_64-linux" "aarch64-linux"]
+      flake-utils.lib.eachDefaultSystem
       (system: let
         pkgs = import nixpkgs {
           inherit system;
@@ -290,10 +289,15 @@
       // {
         inherit lib;
 
-        nixosModules.nixfiles = import ./modules/nixfiles;
+        modules.nixfiles = import ./modules/nixfiles;
 
+        nixosModules.nixfiles = import ./modules/nixos;
         nixosConfigurations =
-          import ./configurations {inherit inputs lib;};
+          import ./nixosConfigurations {inherit inputs lib;};
+
+        darwinModules.nixfiles = import ./modules/darwin;
+        darwinConfigurations =
+          import ./darwinConfigurations {inherit inputs lib;};
 
         # TODO Make it so that self.packages also can use this.
         overlays.default = final: _: {

Consider giving Nix/NixOS a try! <3