about summary refs log tree commit diff
path: root/flake.nix
diff options
context:
space:
mode:
authorAzat Bahawi <azat@bahawi.net>2023-01-30 01:48:52 +0300
committerAzat Bahawi <azat@bahawi.net>2023-01-30 01:48:52 +0300
commite8dbb049452e014fe89df34cb8f29e7c21c37666 (patch)
tree8102c252877057fc5c1d5914b36cbb167927e153 /flake.nix
parent2023-01-05 (diff)
2023-01-30
Diffstat (limited to '')
-rw-r--r--flake.nix42
1 files changed, 18 insertions, 24 deletions
diff --git a/flake.nix b/flake.nix
index ba845a4..4f3eacb 100644
--- a/flake.nix
+++ b/flake.nix
@@ -66,6 +66,13 @@
       };
     };
 
+    impermanence = {
+      type = "github";
+      owner = "nix-community";
+      repo = "impermanence";
+      ref = "master";
+    };
+
     emacs-overlay = {
       type = "github";
       owner = "nix-community";
@@ -98,30 +105,16 @@
       };
     };
 
-    # nil = {
-    #   type = "github";
-    #   owner = "oxalica";
-    #   repo = "nil";
-    #   ref = "main";
-    #   inputs = {
-    #     flake-utils.follows = "flake-utils";
-    #     nixpkgs.follows = "nixpkgs";
-    #   };
-    # };
-
-    # NOTE This[1] is annoying.
-    #
-    # [1]: https://github.com/NixOS/nix/pull/6983#issuecomment-1234335417
-    # nix-minecraft-servers = {
-    #   type = "github";
-    #   owner = "jyooru";
-    #   repo = "nix-minecraft-servers";
-    #   ref = "main";
-    #   inputs = {
-    #     nixpkgs.follows = "nixpkgs";
-    #     utils.inputs.flake-utils.follows = "flake-utils";
-    #   };
-    # };
+    nix-minecraft = {
+      type = "github";
+      owner = "Infinidoge";
+      repo = "nix-minecraft";
+      ref = "master";
+      inputs = {
+        nixpkgs.follows = "nixpkgs";
+        flake-utils.follows = "flake-utils";
+      };
+    };
 
     pollymc = {
       type = "github";
@@ -151,6 +144,7 @@
       repo = "nixos-mailserver";
       ref = "master";
       inputs = {
+        flake-compat.follows = "flake-compat";
         nixpkgs-22_11.follows = "nixpkgs-stable";
         nixpkgs.follows = "nixpkgs";
         utils.follows = "flake-utils";

Consider giving Nix/NixOS a try! <3