about summary refs log tree commit diff
path: root/flake.nix
diff options
context:
space:
mode:
authorAzat Bahawi <azat@bahawi.net>2023-06-01 02:39:11 +0300
committerAzat Bahawi <azat@bahawi.net>2023-06-01 02:39:11 +0300
commitec144aaa8fb8c5a4b65e60bbc31a52d71d6e646a (patch)
tree27a5a684b2def43d0ba00fbb890ed26f572fb060 /flake.nix
parent2023-05-21 (diff)
2023-06-01
Diffstat (limited to '')
-rw-r--r--flake.nix22
1 files changed, 21 insertions, 1 deletions
diff --git a/flake.nix b/flake.nix
index a58fed6..170377e 100644
--- a/flake.nix
+++ b/flake.nix
@@ -74,6 +74,18 @@
       ref = "master";
     };
 
+    nix-vscode-extensions = {
+      type = "github";
+      owner = "nix-community";
+      repo = "nix-vscode-extensions";
+      ref = "master";
+      inputs = {
+        flake-compat.follows = "flake-compat";
+        flake-utils.follows = "flake-utils";
+        nixpkgs.follows = "nixpkgs";
+      };
+    };
+
     arkenfox-nixos = {
       type = "github";
       owner = "dwarfmaster";
@@ -87,6 +99,7 @@
       };
     };
 
+    # TODO Check out https://github.com/nix-community/mineflake
     nix-minecraft = {
       type = "github";
       owner = "Infinidoge";
@@ -286,10 +299,17 @@
             promtool = {
               enable = true;
               name = "promtool";
-              description = "Check Prometheus rules.";
+              description = "Check Prometheus rules";
               entry = "${pkgs.prometheus.cli}/bin/promtool check rules";
               files = "(?x)^(modules/nixos/monitoring/rules/.*\.yaml)$";
             };
+            nixpkgs-lint = {
+              enable = true;
+              name = "nixpkgs-lint";
+              description = "Semantic linter for Nixpkgs using tree-sitter";
+              entry = "${pkgs.nixpkgs-lint}/bin/nixpkgs-lint";
+              files = "(?x)^(packages/.*\.nix)$";
+            };
           };
           settings.deadnix.edit = true;
         };

Consider giving Nix/NixOS a try! <3