about summary refs log tree commit diff
path: root/lib/default.nix
diff options
context:
space:
mode:
authorazahi <azat@bahawi.net>2024-10-10 03:33:47 +0300
committerazahi <azat@bahawi.net>2024-10-10 03:33:47 +0300
commitc6c9929a090aa8022045514e09ecafd57a954c27 (patch)
tree0a71feedcada203c045f94d01bc2d8b733b067ee /lib/default.nix
parent2024-08-20 (diff)
2024-10-10
Diffstat (limited to '')
-rw-r--r--lib/default.nix6
1 files changed, 3 insertions, 3 deletions
diff --git a/lib/default.nix b/lib/default.nix
index aa8df80..662938e 100644
--- a/lib/default.nix
+++ b/lib/default.nix
@@ -1,6 +1,6 @@
 {
-  lib,
   inputs,
+  lib,
   system,
   ...
 }:
@@ -86,7 +86,7 @@ rec {
   # ```
   # nixosConfigurations.machine = nixosSystem {
   #   modules = [
-  #     (_: modulesFromRef "services/security/foobar.nix" "azahi:foobar-fix" "sha256-AAA...")
+  #     (_: moduleFromRef "services/security/foobar.nix" "azahi:foobar-fix" "sha256-AAA...")
   #   ];
   # };
   # ```
@@ -96,7 +96,7 @@ rec {
     imports = [
       (
         let
-          src = builtins.fetchTarball {
+          src = inputs.nixpkgs.legacyPackages.${system}.fetchzip {
             url =
               let
                 cons = splitString ":" ref;

Consider giving Nix/NixOS a try! <3