about summary refs log tree commit diff
path: root/lib/my.nix
diff options
context:
space:
mode:
authorAzat Bahawi <azat@bahawi.net>2022-08-13 12:48:36 +0300
committerAzat Bahawi <azat@bahawi.net>2022-08-13 12:48:36 +0300
commit44d0f54b477ca1d370d0b6c2fa06f5400e151e42 (patch)
tree6de343568f70d643eb897a14f44fca5ba92b3105 /lib/my.nix
parent2022-08-12 (diff)
2022-08-13
Diffstat (limited to '')
-rw-r--r--lib/my.nix12
1 files changed, 11 insertions, 1 deletions
diff --git a/lib/my.nix b/lib/my.nix
index f7c4141..165074b 100644
--- a/lib/my.nix
+++ b/lib/my.nix
@@ -70,6 +70,13 @@ with lib;
                   };
                 };
 
+                # TODO Automate filling of this from the NSD service module.
+                # Right now I need to copy domain defenitions from there to here
+                # manually.
+                #
+                # Something like taking `config.services.nsd.zones[$domain]` and
+                # filtering for actual subdomains. We can remove this option
+                # altogether then.
                 domains = mkOption {
                   description = "External domains that resovle to this address.";
                   type = listOf str;
@@ -128,10 +135,13 @@ with lib;
                 publicKey = "[REDACTED]";
               };
               domains = with my.domain; [
+                "alertmanager.${shire}"
                 "frodo.${rohan}"
                 "frodo.${gondor}"
                 "gotify.${shire}"
-                "monitoring.${shire}"
+                "grafana.${shire}"
+                "loki.${shire}"
+                "prometheus.${shire}"
                 azahi
                 rohan
                 gondor

Consider giving Nix/NixOS a try! <3