about summary refs log tree commit diff
path: root/modules/acme.nix
diff options
context:
space:
mode:
authorazahi <azat@bahawi.net>2025-02-17 02:21:56 +0300
committerazahi <azat@bahawi.net>2025-02-17 02:21:56 +0300
commit59180328cda59817d71cd58c8f48ead047375064 (patch)
tree2cdd7d1bfa309839ef624c19daf283f510aacf69 /modules/acme.nix
parent2025-02-05 (diff)
2025-02-17
Diffstat (limited to '')
-rw-r--r--modules/acme.nix13
1 files changed, 6 insertions, 7 deletions
diff --git a/modules/acme.nix b/modules/acme.nix
index bbaf434..e675d1d 100644
--- a/modules/acme.nix
+++ b/modules/acme.nix
@@ -1,11 +1,10 @@
 { config, lib, ... }:
-with lib;
 let
   cfg = config.nixfiles.modules.acme;
 in
 {
   imports = [
-    (mkAliasOptionModule
+    (lib.mkAliasOptionModule
       [ "certs" ]
       [
         "security"
@@ -16,16 +15,16 @@ in
   ];
 
   options.nixfiles.modules.acme = {
-    enable = mkEnableOption "ACME";
+    enable = lib.mkEnableOption "ACME";
 
-    email = mkOption {
+    email = lib.mkOption {
       description = "Email for notifications.";
-      type = with types; str;
-      default = "hostmaster@${my.domain.shire}";
+      type = lib.types.str;
+      default = "hostmaster@${lib.my.domain.shire}";
     };
   };
 
-  config = mkIf cfg.enable {
+  config = lib.mkIf cfg.enable {
     ark.directories = [ "/var/lib/acme" ];
 
     security.acme = {

Consider giving Nix/NixOS a try! <3