about summary refs log tree commit diff
path: root/modules/clickhouse.nix
diff options
context:
space:
mode:
authorAzat Bahawi <azat@bahawi.net>2024-05-05 14:28:31 +0300
committerAzat Bahawi <azat@bahawi.net>2024-05-05 14:28:31 +0300
commit389becf9700d3dee7f09073ce4d235fc7c30b5c8 (patch)
tree3db9d75bd5275614fc904184c97b3133f38bc3d0 /modules/clickhouse.nix
parent2024-05-04 (diff)
2024-05-05
Diffstat (limited to '')
-rw-r--r--modules/clickhouse.nix16
1 files changed, 15 insertions, 1 deletions
diff --git a/modules/clickhouse.nix b/modules/clickhouse.nix
index 12dc7fa..6bb53bb 100644
--- a/modules/clickhouse.nix
+++ b/modules/clickhouse.nix
@@ -1,4 +1,10 @@
-{ config, lib, ... }:
+{
+  config,
+  inputs,
+  lib,
+  this,
+  ...
+}:
 with lib;
 let
   cfg = config.nixfiles.modules.clickhouse;
@@ -12,5 +18,13 @@ in
     services.clickhouse = {
       enable = true;
     };
+
+    topology = {
+      nodes.${this.hostname}.services.clickhouse = {
+        name = "ClickHouse";
+        icon = "${inputs.homelab-svg-assets}/assets/postgresql.svg";
+        details.listen.text = "127.0.0.1:8123";
+      };
+    };
   };
 }

Consider giving Nix/NixOS a try! <3