about summary refs log tree commit diff
path: root/modules/common/direnv.nix
diff options
context:
space:
mode:
authorAzat Bahawi <azat@bahawi.net>2023-07-09 14:22:15 +0300
committerAzat Bahawi <azat@bahawi.net>2023-07-09 14:22:15 +0300
commitab63f2eb09ed6633a7fad7a1a72b60bb14d5c85c (patch)
tree72f32b1f4e2f0e57b90722ebd5b0ec19e8f8f15b /modules/common/direnv.nix
parent2023-07-03 (diff)
2023-07-09
Diffstat (limited to '')
-rw-r--r--modules/common/direnv.nix12
1 files changed, 6 insertions, 6 deletions
diff --git a/modules/common/direnv.nix b/modules/common/direnv.nix
index b235cee..6ec39d1 100644
--- a/modules/common/direnv.nix
+++ b/modules/common/direnv.nix
@@ -10,13 +10,13 @@ in {
     mkEnableOption "direnv";
 
   config = mkIf cfg.enable {
-    hm = {
-      programs.direnv = {
-        enable = true;
-        nix-direnv.enable = true;
+    hm.programs.direnv = {
+      enable = true;
+      config.global = {
+        strict_env = true;
+        warn_timeout = 0;
       };
-
-      home.sessionVariables.DIRENV_LOG_FORMAT = "";
+      nix-direnv.enable = true;
     };
   };
 }

Consider giving Nix/NixOS a try! <3