about summary refs log tree commit diff
path: root/modules/common/eza.nix
diff options
context:
space:
mode:
authorAzat Bahawi <azat@bahawi.net>2023-12-03 02:52:28 +0300
committerAzat Bahawi <azat@bahawi.net>2023-12-03 02:52:28 +0300
commitcec9f7acd5e5e365563212c5144394f71dd90b27 (patch)
tree667b308a7241ab2e8f3fa4e2b53cc7888e876c68 /modules/common/eza.nix
parent2023-11-29 (diff)
2023-12-03
Diffstat (limited to '')
-rw-r--r--modules/common/eza.nix21
1 files changed, 21 insertions, 0 deletions
diff --git a/modules/common/eza.nix b/modules/common/eza.nix
new file mode 100644
index 0000000..be590b4
--- /dev/null
+++ b/modules/common/eza.nix
@@ -0,0 +1,21 @@
+{
+  config,
+  lib,
+  pkgs,
+  ...
+}:
+with lib; let
+  cfg = config.nixfiles.modules.eza;
+in {
+  options.nixfiles.modules.eza.enable = mkEnableOption "eza, an alternative to ls";
+
+  config = mkIf cfg.enable {
+    nixfiles.modules.common.shell.aliases = rec {
+      ls = "eza --smart-group --dereference";
+      ll = "${ls} --long --grid";
+      la = "${ll} --header --all";
+    };
+
+    hm.home.packages = [pkgs.eza];
+  };
+}

Consider giving Nix/NixOS a try! <3