about summary refs log tree commit diff
path: root/modules/common/git.nix
diff options
context:
space:
mode:
authorAzat Bahawi <azat@bahawi.net>2023-10-21 04:03:28 +0300
committerAzat Bahawi <azat@bahawi.net>2023-10-21 04:03:28 +0300
commite591de4986b1c80f2529b7ba9b0601900a599276 (patch)
tree5cac69f30a8e85791ad6aa058a8abbc2b2b12acb /modules/common/git.nix
parent2023-10-13 (diff)
2023-10-21
Diffstat (limited to '')
-rw-r--r--modules/common/git.nix6
1 files changed, 6 insertions, 0 deletions
diff --git a/modules/common/git.nix b/modules/common/git.nix
index 70fb7c7..de401fb 100644
--- a/modules/common/git.nix
+++ b/modules/common/git.nix
@@ -68,6 +68,7 @@ in {
                 submodule = "log";
               };
               init.defaultBranch = "master";
+              push.autoSetupRemote = true;
               status.submoduleSummary = true;
               github.user = my.username;
               gitlab.user = my.username;
@@ -96,6 +97,11 @@ in {
           in {
             fuck = "!${git} reset --hard && ${git} clean -fdx";
             gud = ''commit -m "git gud"'';
+            review = "!${git} lg @{push}..";
+            reword = "commit --amend";
+            tree = "log --graph --date=relative --pretty=tformat:'%Cred%h%Creset -%C(auto)%d%Creset %s %Cgreen(%an %ad)%Creset'";
+            uncommit = "reset --soft HEAD~1";
+            untrack = "rm --cache --";
             wtc = "!${curl} -sq whatthecommit.com/index.txt | ${git} commit -F -";
           };
 

Consider giving Nix/NixOS a try! <3