about summary refs log tree commit diff
path: root/modules/common/profiles/dev/default.nix
diff options
context:
space:
mode:
authorAzat Bahawi <azat@bahawi.net>2024-01-07 23:57:45 +0300
committerAzat Bahawi <azat@bahawi.net>2024-01-07 23:57:45 +0300
commit5a4e7e22a6975ebc3de70e68446ff53109c64170 (patch)
tree0004db42ea38a75bf9dc413f6b77e501f2270fad /modules/common/profiles/dev/default.nix
parent2024-01-05 (diff)
2024-01-07
Diffstat (limited to '')
-rw-r--r--modules/common/profiles/dev/default.nix18
1 files changed, 2 insertions, 16 deletions
diff --git a/modules/common/profiles/dev/default.nix b/modules/common/profiles/dev/default.nix
index 2d0c0f6..ecd586a 100644
--- a/modules/common/profiles/dev/default.nix
+++ b/modules/common/profiles/dev/default.nix
@@ -20,6 +20,7 @@ in {
       bat.enable = true;
       curl.enable = true;
       direnv.enable = true;
+      editorconfig.enable = true;
       git.client.enable = true;
       gnupg.enable = true;
       nmap.enable = true;
@@ -28,25 +29,9 @@ in {
 
     hm.home = {
       file = {
-        ".editorconfig".source = ./editorconfig.ini;
-
         ".gdbinit".source = ./gdbinit;
 
         ".ghc/ghci.conf".source = ./ghci.conf;
-
-        ".stack/config.yaml".text = generators.toYAML {} {
-          templates.params = rec {
-            author-name = my.fullname;
-            author-email = my.email;
-            copyright = "Copyright (c) 2023 ${author-name} <${author-email}>";
-            github-username = my.username;
-          };
-        };
-
-        ".stack/global-project/stack.yaml".text = generators.toYAML {} {
-          packages = [];
-          resolver = "lts-21.20";
-        };
       };
 
       sessionVariables = rec {
@@ -74,6 +59,7 @@ in {
         CARGO_HOME = "${config.my.home}/.cargo";
 
         GOPATH = "${config.my.home}/.go";
+        GORE_HOME = "${config.my.home}/.gore";
 
         PYTHONSTARTUP = ./pystartup.py;
       };

Consider giving Nix/NixOS a try! <3