about summary refs log tree commit diff
path: root/modules/common/systemd.nix
diff options
context:
space:
mode:
authorAzat Bahawi <azat@bahawi.net>2024-06-29 01:43:37 +0300
committerAzat Bahawi <azat@bahawi.net>2024-06-29 01:43:37 +0300
commit31ab954db3dbc0a07e7b58c59da003088ee7943d (patch)
tree774b3cc777d537c33475255b4bb0eb190fefd2ba /modules/common/systemd.nix
parent2024-06-27 (diff)
2024-06-29
Diffstat (limited to '')
-rw-r--r--modules/common/systemd.nix23
1 files changed, 19 insertions, 4 deletions
diff --git a/modules/common/systemd.nix b/modules/common/systemd.nix
index aac1647..81df05c 100644
--- a/modules/common/systemd.nix
+++ b/modules/common/systemd.nix
@@ -1,4 +1,10 @@
-{ config, pkgs, ... }:
+{
+  config,
+  pkgs,
+  lib,
+  ...
+}:
+with lib;
 {
   ark = {
     files = [ "/etc/machine-id" ];
@@ -16,9 +22,18 @@
     };
   };
 
-  services.journald.extraConfig = ''
-    SystemMaxUse=5G
-  '';
+  services = {
+    resolved = {
+      llmnr = "false";
+      dnsovertls = "opportunistic";
+      domains = mapAttrsToList (_: v: v) my.domain;
+      fallbackDns = map (v: "${v}#dns.quad9.net") dns.const.quad9.default;
+    };
+
+    journald.extraConfig = ''
+      SystemMaxUse=5G
+    '';
+  };
 
   systemd =
     let

Consider giving Nix/NixOS a try! <3