about summary refs log tree commit diff
path: root/modules/common/vscode.nix
diff options
context:
space:
mode:
authorAzat Bahawi <azat@bahawi.net>2023-02-19 21:35:36 +0300
committerAzat Bahawi <azat@bahawi.net>2023-02-19 21:35:36 +0300
commit9e3f4268c87b0d1a64e9429ea173252a5f774ec5 (patch)
tree12896bfa12d7175a22c1e8091cfcc785112df12b /modules/common/vscode.nix
parent2023-02-19 (diff)
2023-02-19
Diffstat (limited to '')
-rw-r--r--modules/common/vscode.nix34
1 files changed, 7 insertions, 27 deletions
diff --git a/modules/common/vscode.nix b/modules/common/vscode.nix
index 6671973..92ce5b5 100644
--- a/modules/common/vscode.nix
+++ b/modules/common/vscode.nix
@@ -132,35 +132,15 @@ in {
 
         git.allowForcePush = true;
 
-        vim = let
-          applyInputMethod = {
-            "ibus" = let
-              bin = "${pkgs.ibus}/bin/ibus";
-            in {
-              enable = true;
-              defaultIM = "xkb:us::eng";
-              obtainIMCmd = "${bin} engine";
-              switchIMCmd = "${bin} engine {im}";
-            };
-            "fcitx" = let
-              bin = "${pkgs.fcitx}/bin/fcitx-remote";
-            in {
-              enable = true;
-              defaultIM = "1";
-              obtainIMCmd = bin;
-              switchIMCmd = "${bin} -t {im}";
-            };
-          };
-        in
-          mkIf cfg.vim.enable rec {
-            easymotion = true;
-            easymotionMarkerFontFamily = fontFamily;
-            easymotionMarkerFontSize = fontSize;
+        vim = mkIf cfg.vim.enable rec {
+          easymotion = true;
+          easymotionMarkerFontFamily = fontFamily;
+          easymotionMarkerFontSize = fontSize;
 
-            leader = " ";
+          leader = " ";
 
-            useSystemClipboard = true;
-          };
+          useSystemClipboard = true;
+        };
       };
     };
   };

Consider giving Nix/NixOS a try! <3