about summary refs log tree commit diff
path: root/modules/direnv.nix
diff options
context:
space:
mode:
authorAzat Bahawi <azat@bahawi.net>2024-07-10 14:02:06 +0300
committerAzat Bahawi <azat@bahawi.net>2024-07-10 14:02:06 +0300
commita88092202ccfdb981c6aef3270bdef20e7530f5f (patch)
treef6f2f82e7575aeead163bcf0c93bab494e7e70ce /modules/direnv.nix
parent2024-06-29 (diff)
2024-07-10
Diffstat (limited to '')
-rw-r--r--modules/direnv.nix16
1 files changed, 6 insertions, 10 deletions
diff --git a/modules/direnv.nix b/modules/direnv.nix
index ececad8..709a73a 100644
--- a/modules/direnv.nix
+++ b/modules/direnv.nix
@@ -7,17 +7,13 @@ in
   options.nixfiles.modules.direnv.enable = mkEnableOption "direnv";
 
   config = mkIf cfg.enable {
-    hm = {
-      home.sessionVariables.DIRENV_LOG_FORMAT = "";
-
-      programs.direnv = {
-        enable = true;
-        config.global = {
-          strict_env = true;
-          warn_timeout = "1h";
-        };
-        nix-direnv.enable = true;
+    hm.programs.direnv = {
+      enable = true;
+      config.global = {
+        strict_env = true;
+        warn_timeout = "1h";
       };
+      nix-direnv.enable = true;
     };
   };
 }

Consider giving Nix/NixOS a try! <3