about summary refs log tree commit diff
path: root/modules/dwm.nix
diff options
context:
space:
mode:
authorazahi <azat@bahawi.net>2025-02-17 02:21:56 +0300
committerazahi <azat@bahawi.net>2025-02-17 02:21:56 +0300
commit59180328cda59817d71cd58c8f48ead047375064 (patch)
tree2cdd7d1bfa309839ef624c19daf283f510aacf69 /modules/dwm.nix
parent2025-02-05 (diff)
2025-02-17
Diffstat (limited to '')
-rw-r--r--modules/dwm.nix9
1 files changed, 4 insertions, 5 deletions
diff --git a/modules/dwm.nix b/modules/dwm.nix
index 912be0c..9b38900 100644
--- a/modules/dwm.nix
+++ b/modules/dwm.nix
@@ -4,14 +4,13 @@
   pkgs,
   ...
 }:
-with lib;
 let
   cfg = config.nixfiles.modules.dwm;
 in
 {
-  options.nixfiles.modules.dwm.enable = mkEnableOption "dwm";
+  options.nixfiles.modules.dwm.enable = lib.mkEnableOption "dwm";
 
-  config = mkIf cfg.enable {
+  config = lib.mkIf cfg.enable {
     nixfiles.modules.x11.enable = true;
 
     hm.xsession = {
@@ -93,7 +92,7 @@ in
                   NULL,
                 };
                 static const char *termcmd[] = {
-                  "${getExe pkgs.alacritty}",
+                  "${lib.getExe pkgs.alacritty}",
                   NULL,
                 };
 
@@ -148,7 +147,7 @@ in
               '';
           };
         in
-        getExe' pkg "dwm";
+        lib.getExe' pkg "dwm";
     };
 
     hm.services.dwm-status = {

Consider giving Nix/NixOS a try! <3