about summary refs log tree commit diff
path: root/modules/editorconfig.nix
diff options
context:
space:
mode:
authorazahi <azat@bahawi.net>2025-02-17 02:21:56 +0300
committerazahi <azat@bahawi.net>2025-02-17 02:21:56 +0300
commit59180328cda59817d71cd58c8f48ead047375064 (patch)
tree2cdd7d1bfa309839ef624c19daf283f510aacf69 /modules/editorconfig.nix
parent2025-02-05 (diff)
2025-02-17
Diffstat (limited to '')
-rw-r--r--modules/editorconfig.nix5
1 files changed, 2 insertions, 3 deletions
diff --git a/modules/editorconfig.nix b/modules/editorconfig.nix
index e7f55ff..56cb20c 100644
--- a/modules/editorconfig.nix
+++ b/modules/editorconfig.nix
@@ -1,12 +1,11 @@
 { config, lib, ... }:
-with lib;
 let
   cfg = config.nixfiles.modules.editorconfig;
 in
 {
-  options.nixfiles.modules.editorconfig.enable = mkEnableOption "Editorconfig";
+  options.nixfiles.modules.editorconfig.enable = lib.mkEnableOption "Editorconfig";
 
-  config = mkIf cfg.enable {
+  config = lib.mkIf cfg.enable {
     hm.editorconfig = {
       enable = true;
       settings = {

Consider giving Nix/NixOS a try! <3