about summary refs log tree commit diff
path: root/modules/games/default.nix
diff options
context:
space:
mode:
authorazahi <azat@bahawi.net>2025-02-17 02:21:56 +0300
committerazahi <azat@bahawi.net>2025-02-17 02:21:56 +0300
commit59180328cda59817d71cd58c8f48ead047375064 (patch)
tree2cdd7d1bfa309839ef624c19daf283f510aacf69 /modules/games/default.nix
parent2025-02-05 (diff)
2025-02-17
Diffstat (limited to '')
-rw-r--r--modules/games/default.nix9
1 files changed, 4 insertions, 5 deletions
diff --git a/modules/games/default.nix b/modules/games/default.nix
index b70b94b..17090bb 100644
--- a/modules/games/default.nix
+++ b/modules/games/default.nix
@@ -1,16 +1,15 @@
 { config, lib, ... }:
-with lib;
 let
   cfg = config.nixfiles.modules.games;
 in
 {
-  imports = attrValues (modulesIn ./.);
+  imports = lib.modulesIn ./. |> lib.attrValues;
 
-  options.nixfiles.modules.games.enable32BitSupport = mkEnableOption "support for games";
+  options.nixfiles.modules.games.enable32BitSupport = lib.mkEnableOption "support for games";
 
-  config = mkMerge [
+  config = lib.mkMerge [
     { hardware.graphics.enable = true; }
-    (mkIf cfg.enable32BitSupport {
+    (lib.mkIf cfg.enable32BitSupport {
       services = {
         jack.alsa.support32Bit = config.services.jack.alsa.enable;
         pipewire.alsa.support32Bit = config.services.pipewire.alsa.enable;

Consider giving Nix/NixOS a try! <3