about summary refs log tree commit diff
path: root/modules/gotify.nix
diff options
context:
space:
mode:
authorazahi <azat@bahawi.net>2025-02-17 02:21:56 +0300
committerazahi <azat@bahawi.net>2025-02-17 02:21:56 +0300
commit59180328cda59817d71cd58c8f48ead047375064 (patch)
tree2cdd7d1bfa309839ef624c19daf283f510aacf69 /modules/gotify.nix
parent2025-02-05 (diff)
2025-02-17
Diffstat (limited to '')
-rw-r--r--modules/gotify.nix11
1 files changed, 5 insertions, 6 deletions
diff --git a/modules/gotify.nix b/modules/gotify.nix
index ad9b277..2a5dd55 100644
--- a/modules/gotify.nix
+++ b/modules/gotify.nix
@@ -4,17 +4,16 @@
   libNginx,
   ...
 }:
-with lib;
 let
   cfg = config.nixfiles.modules.gotify;
 in
 {
   options.nixfiles.modules.gotify = {
-    enable = mkEnableOption "Gotify";
+    enable = lib.mkEnableOption "Gotify";
 
-    domain = mkOption {
+    domain = lib.mkOption {
       description = "Domain name sans protocol scheme.";
-      type = with types; str;
+      type = lib.types.str;
       default = "gotify.${config.networking.domain}";
     };
   };
@@ -23,7 +22,7 @@ in
     let
       db = "gotify";
     in
-    mkIf cfg.enable {
+    lib.mkIf cfg.enable {
       nixfiles.modules = {
         nginx = {
           enable = true;
@@ -70,7 +69,7 @@ in
         ];
         environment = {
           GOTIFY_DATABASE_DIALECT = "postgres";
-          GOTIFY_DATABASE_CONNECTION = concatStringsSep " " [
+          GOTIFY_DATABASE_CONNECTION = lib.concatStringsSep " " [
             "host=/run/postgresql"
             "user=${db}"
             "dbname=${db}"

Consider giving Nix/NixOS a try! <3