about summary refs log tree commit diff
path: root/modules/jackett.nix
diff options
context:
space:
mode:
authorAzat Bahawi <azat@bahawi.net>2024-05-05 14:28:31 +0300
committerAzat Bahawi <azat@bahawi.net>2024-05-05 14:28:31 +0300
commit389becf9700d3dee7f09073ce4d235fc7c30b5c8 (patch)
tree3db9d75bd5275614fc904184c97b3133f38bc3d0 /modules/jackett.nix
parent2024-05-04 (diff)
2024-05-05
Diffstat (limited to '')
-rw-r--r--modules/jackett.nix11
1 files changed, 11 insertions, 0 deletions
diff --git a/modules/jackett.nix b/modules/jackett.nix
index 492e77a..07a5b16 100644
--- a/modules/jackett.nix
+++ b/modules/jackett.nix
@@ -1,7 +1,9 @@
 {
   config,
+  inputs,
   lib,
   libNginx,
+  this,
   ...
 }:
 with lib;
@@ -32,5 +34,14 @@ in
     };
 
     services.jackett.enable = true;
+
+    topology = with cfg; {
+      nodes.${this.hostname}.services.jackett = {
+        name = "Jackett";
+        icon = "${inputs.homelab-svg-assets}/assets/jackett.svg";
+        info = domain;
+        details.listen.text = "127.0.0.1:9117";
+      };
+    };
   };
 }

Consider giving Nix/NixOS a try! <3