about summary refs log tree commit diff
path: root/modules/matrix/dendrite.nix
diff options
context:
space:
mode:
authorazahi <azat@bahawi.net>2025-02-17 02:21:56 +0300
committerazahi <azat@bahawi.net>2025-02-17 02:21:56 +0300
commit59180328cda59817d71cd58c8f48ead047375064 (patch)
tree2cdd7d1bfa309839ef624c19daf283f510aacf69 /modules/matrix/dendrite.nix
parent2025-02-05 (diff)
2025-02-17
Diffstat (limited to '')
-rw-r--r--modules/matrix/dendrite.nix12
1 files changed, 5 insertions, 7 deletions
diff --git a/modules/matrix/dendrite.nix b/modules/matrix/dendrite.nix
index 89704ea..960096c 100644
--- a/modules/matrix/dendrite.nix
+++ b/modules/matrix/dendrite.nix
@@ -238,13 +238,11 @@ in
           };
       };
 
-      topology = with cfg; {
-        nodes.${this.hostname}.services.dendrite = {
-          name = "Dendrite";
-          icon = "${inputs.homelab-svg-assets}/assets/matrix-white.svg";
-          info = domain;
-          details.listen.text = "127.0.0.1:${toString port}";
-        };
+      topology.nodes.${this.hostname}.services.dendrite = {
+        name = "Dendrite";
+        icon = "${inputs.homelab-svg-assets}/assets/matrix-white.svg";
+        info = cfg.domain;
+        details.listen.text = "127.0.0.1:${toString cfg.port}";
       };
     };
 }

Consider giving Nix/NixOS a try! <3