about summary refs log tree commit diff
path: root/modules/nixos/clickhouse.nix
diff options
context:
space:
mode:
authorAzat Bahawi <azat@bahawi.net>2023-09-20 15:26:47 +0300
committerAzat Bahawi <azat@bahawi.net>2023-09-20 15:26:47 +0300
commit837fc97b30a41d766dd53a2370f6cb1d26364f9a (patch)
tree63ae83af789930c9a2035b9f9e43fbee166ab27b /modules/nixos/clickhouse.nix
parent2023-09-16 (diff)
2023-09-20
Diffstat (limited to '')
-rw-r--r--modules/nixos/clickhouse.nix18
1 files changed, 18 insertions, 0 deletions
diff --git a/modules/nixos/clickhouse.nix b/modules/nixos/clickhouse.nix
new file mode 100644
index 0000000..4fae683
--- /dev/null
+++ b/modules/nixos/clickhouse.nix
@@ -0,0 +1,18 @@
+{
+  config,
+  lib,
+  ...
+}:
+with lib; let
+  cfg = config.nixfiles.modules.clickhouse;
+in {
+  options.nixfiles.modules.clickhouse = {
+    enable = mkEnableOption "Clickhouse";
+  };
+
+  config = mkIf cfg.enable {
+    services.clickhouse = {
+      enable = true;
+    };
+  };
+}

Consider giving Nix/NixOS a try! <3