about summary refs log tree commit diff
path: root/modules/nixos/common/nix.nix
diff options
context:
space:
mode:
authorAzat Bahawi <azat@bahawi.net>2024-04-21 02:15:42 +0300
committerAzat Bahawi <azat@bahawi.net>2024-04-21 02:15:42 +0300
commite6ed60548397627bf10f561f9438201dbba0a36e (patch)
treef9a84c5957d2cc4fcd148065ee9365a0c851ae1c /modules/nixos/common/nix.nix
parent2024-04-18 (diff)
2024-04-21
Diffstat (limited to '')
-rw-r--r--modules/nixos/common/nix.nix35
1 files changed, 0 insertions, 35 deletions
diff --git a/modules/nixos/common/nix.nix b/modules/nixos/common/nix.nix
deleted file mode 100644
index 146575d..0000000
--- a/modules/nixos/common/nix.nix
+++ /dev/null
@@ -1,35 +0,0 @@
-{
-  config,
-  inputs,
-  lib,
-  ...
-}:
-with lib;
-let
-  cfg = config.nixfiles.modules.common.nix;
-in
-{
-  options.nixfiles.modules.common.nix.allowedUnfreePackages = mkOption {
-    description = "A list of allowed unfree packages.";
-    type = with types; listOf str;
-    default = [ ];
-  };
-
-  config = {
-    nix = {
-      daemonCPUSchedPolicy = "idle";
-      daemonIOSchedClass = "idle";
-      daemonIOSchedPriority = 7;
-    };
-
-    nixpkgs.config.allowUnfreePredicate = p: elem (getName p) cfg.allowedUnfreePackages;
-
-    system.stateVersion = with builtins; head (split "\n" (readFile "${inputs.nixpkgs}/.version"));
-
-    environment = {
-      sessionVariables.NIX_SHELL_PRESERVE_PROMPT = "1";
-      localBinInPath = true;
-      defaultPackages = [ ];
-    };
-  };
-}

Consider giving Nix/NixOS a try! <3