about summary refs log tree commit diff
path: root/modules/nixos/firefox/default.nix
diff options
context:
space:
mode:
authorAzat Bahawi <azat@bahawi.net>2024-03-02 20:30:02 +0300
committerAzat Bahawi <azat@bahawi.net>2024-03-02 20:30:02 +0300
commit482bcef47a3b7ee63553c58d200065857ec42b1c (patch)
treeface7032b62c8957df4a84b2fc0c4adc47020f9e /modules/nixos/firefox/default.nix
parent2024-03-01 (diff)
2024-03-02
Diffstat (limited to '')
-rw-r--r--modules/nixos/firefox/default.nix57
1 files changed, 31 insertions, 26 deletions
diff --git a/modules/nixos/firefox/default.nix b/modules/nixos/firefox/default.nix
index ce8b3ee..d192ae1 100644
--- a/modules/nixos/firefox/default.nix
+++ b/modules/nixos/firefox/default.nix
@@ -22,6 +22,11 @@ in {
 
       home.packages = with pkgs; [profile-cleaner];
 
+      stylix.targets.firefox = {
+        enable = true;
+        profileNames = ["default"];
+      };
+
       programs.firefox = {
         enable = true;
 
@@ -32,34 +37,34 @@ in {
         profiles.default = let
           mkCssWithRoot = css:
             mkMerge [
-              (with config.colourScheme; ''
+              (with config.colors.withHashtag; ''
                 :root {
-                  --black: ${black};
-                  --red: ${red};
-                  --green: ${green};
-                  --yellow: ${yellow};
-                  --blue: ${blue};
-                  --magenta: ${magenta};
-                  --cyan: ${cyan};
-                  --white: ${white};
-                  --bright-black: ${brightBlack};
-                  --bright-red: ${brightRed};
-                  --bright-green: ${brightGreen};
-                  --bright-yellow: ${brightYellow};
-                  --bright-blue: ${brightBlue};
-                  --bright-magenta: ${brightMagenta};
-                  --bright-cyan: ${brightCyan};
-                  --bright-white: ${brightWhite};
-                  --background: ${background};
-                  --foreground: ${foreground};
+                  --black: ${base01};
+                  --red: ${base08};
+                  --green: ${base0B};
+                  --yellow: ${base09};
+                  --blue: ${base0D};
+                  --magenta: ${base0E};
+                  --cyan: ${base0C};
+                  --white: ${base06};
+                  --bright-black: ${base02};
+                  --bright-red: ${base12};
+                  --bright-green: ${base14};
+                  --bright-yellow: ${base13};
+                  --bright-blue: ${base16};
+                  --bright-magenta: ${base17};
+                  --bright-cyan: ${base15};
+                  --bright-white: ${base07};
+                  --background: ${base00};
+                  --foreground: ${base02};
               '')
-              (with config.fontScheme; ''
-                  --sans-serif-font-family: "${sansSerifFont.family}", "${sansSerifFontFallback.family}", sans-serif;
-                  --sans-serif-font-size: ${toString sansSerifFont.size}px;
-                  --serif-font-family: "${serifFont.family}", "${serifFontFallback.family}", serif;
-                  --serif-font-size: ${toString serifFont.size}px;
-                  --monospace-font-family: "${monospaceFont.family}", "${monospaceFontFallback.family}", monospace;
-                  --monospace-font-size: ${toString monospaceFont.size}px;
+              (with config.stylix.fonts; ''
+                  --sans-serif-font-family: "${sansSerif.name}", sans-serif;
+                  --sans-serif-font-size: ${toString sizes.applications};
+                  --serif-font-family: "${serif.name}", serif;
+                  --serif-font-size: ${toString sizes.applications};
+                  --monospace-font-family: "${monospace.name}", monospace;
+                  --monospace-font-size: ${toString sizes.applications};
                 }
               '')
               (builtins.readFile css)

Consider giving Nix/NixOS a try! <3