about summary refs log tree commit diff
path: root/modules/nixos/games/gamemode.nix
diff options
context:
space:
mode:
authorAzat Bahawi <azat@bahawi.net>2023-04-07 19:35:15 +0300
committerAzat Bahawi <azat@bahawi.net>2023-04-07 19:35:15 +0300
commitdae3149a93cab4d1140526e15eb928d275f56128 (patch)
tree2b567413cd9f6882c616fee5aba7392281ac95fa /modules/nixos/games/gamemode.nix
parent2023-04-04 (diff)
2023-04-07
Diffstat (limited to '')
-rw-r--r--modules/nixos/games/gamemode.nix8
1 files changed, 7 insertions, 1 deletions
diff --git a/modules/nixos/games/gamemode.nix b/modules/nixos/games/gamemode.nix
index 051d12e..193a764 100644
--- a/modules/nixos/games/gamemode.nix
+++ b/modules/nixos/games/gamemode.nix
@@ -9,5 +9,11 @@ in {
   options.nixfiles.modules.games.gamemode.enable =
     mkEnableOption "Feral GameMode";
 
-  config = mkIf cfg.enable {programs.gamemode.enable = true;};
+  config = mkIf cfg.enable {
+    hm.xdg.configFile."gamemode.ini".text = generators.toINI {} {
+      general.softrealtime = "auto";
+    };
+
+    programs.gamemode.enable = true;
+  };
 }

Consider giving Nix/NixOS a try! <3