about summary refs log tree commit diff
path: root/modules/nixos/gnupg.nix
diff options
context:
space:
mode:
authorAzat Bahawi <azat@bahawi.net>2024-03-17 17:52:16 +0300
committerAzat Bahawi <azat@bahawi.net>2024-03-17 17:52:16 +0300
commitaa5ac7a7a16c3671b71eb5cac2512398a7e5bbe9 (patch)
tree314489d2e340c897eda97370fa22faf0b2a5248a /modules/nixos/gnupg.nix
parent2024-03-10 (diff)
2024-03-17
Diffstat (limited to '')
-rw-r--r--modules/nixos/gnupg.nix7
1 files changed, 4 insertions, 3 deletions
diff --git a/modules/nixos/gnupg.nix b/modules/nixos/gnupg.nix
index b86be9b..5300554 100644
--- a/modules/nixos/gnupg.nix
+++ b/modules/nixos/gnupg.nix
@@ -1,6 +1,7 @@
 {
   config,
   lib,
+  pkgs,
   ...
 }:
 with lib; let
@@ -8,8 +9,8 @@ with lib; let
 in {
   options.nixfiles.modules.gnupg.pinentry = mkOption {
     description = "Name of a pinentry implementation.";
-    type = types.str;
-    default = "curses";
+    type = types.package;
+    default = pkgs.pinentry-curses;
   };
 
   config = mkIf cfg.enable {
@@ -31,7 +32,7 @@ in {
 
         sshKeys = [my.pgp.grip];
 
-        pinentryFlavor = cfg.pinentry;
+        pinentryPackage = cfg.pinentry;
       };
     };
   };

Consider giving Nix/NixOS a try! <3