about summary refs log tree commit diff
path: root/modules/nixos/openssh.nix
diff options
context:
space:
mode:
authorAzat Bahawi <azat@bahawi.net>2023-02-19 17:50:35 +0300
committerAzat Bahawi <azat@bahawi.net>2023-02-19 17:50:35 +0300
commit91fb4f28ef5d87e8bcf7749928d30ba4a9cbbd34 (patch)
treee07291fcb1cf62a561ffe58d1fd8e2968ff6fcb3 /modules/nixos/openssh.nix
parent2023-02-15 (diff)
2023-02-19
Diffstat (limited to '')
-rw-r--r--modules/nixos/openssh.nix18
1 files changed, 8 insertions, 10 deletions
diff --git a/modules/nixos/openssh.nix b/modules/nixos/openssh.nix
index c7a144e..6f4614c 100644
--- a/modules/nixos/openssh.nix
+++ b/modules/nixos/openssh.nix
@@ -18,16 +18,14 @@ in {
   };
 
   config = mkIf cfg.server.enable {
-    # FIXME This is mounted after the activation script is launched.
-    ark = {
-      files = [
-        "/etc/ssh/ssh_host_ed25519_key"
-        "/etc/ssh/ssh_host_ed25519_key.pub"
-        "/etc/ssh/ssh_host_rsa_key"
-        "/etc/ssh/ssh_host_rsa_key.pub"
-      ];
-      # directories = ["/etc/ssh/authorized_keys.d"];
-    };
+    # authorized_keys is not added here because it only contains my SSH keys and
+    # all non-declarative ones are located in the home directory.
+    ark.files = [
+      "/etc/ssh/ssh_host_ed25519_key"
+      "/etc/ssh/ssh_host_ed25519_key.pub"
+      "/etc/ssh/ssh_host_rsa_key"
+      "/etc/ssh/ssh_host_rsa_key.pub"
+    ];
 
     programs.mosh.enable = true;
 

Consider giving Nix/NixOS a try! <3