about summary refs log tree commit diff
path: root/modules/nixos/profiles/headful.nix
diff options
context:
space:
mode:
authorAzat Bahawi <azat@bahawi.net>2023-03-20 03:24:54 +0300
committerAzat Bahawi <azat@bahawi.net>2023-03-20 03:24:54 +0300
commit1ea1b781a142a41b72aed4bfc408233732034241 (patch)
treeff1124f7c52fdfcaa864e6866c22a7acf68f7c55 /modules/nixos/profiles/headful.nix
parent2023-03-16 (diff)
2023-03-20
Diffstat (limited to '')
-rw-r--r--modules/nixos/profiles/headful.nix33
1 files changed, 32 insertions, 1 deletions
diff --git a/modules/nixos/profiles/headful.nix b/modules/nixos/profiles/headful.nix
index 67bec29..6b19595 100644
--- a/modules/nixos/profiles/headful.nix
+++ b/modules/nixos/profiles/headful.nix
@@ -28,7 +28,38 @@ in {
         tor-browser
       ];
 
-      programs.bash.shellAliases.open = "${pkgs.xdg-utils}/bin/xdg-open";
+      programs = {
+        bash.shellAliases.open = "${pkgs.xdg-utils}/bin/xdg-open";
+
+        thunderbird = {
+          enable = true;
+          profiles.default.isDefault = true;
+          settings = {
+            "app.update.auto" = false;
+            "browser.search.region" = "US";
+            "browser.search.update" = false;
+            "datareporting.healthreport.uploadEnabled" = false;
+            "full-screen-api.warning.delay" = 0;
+            "full-screen-api.warning.timeout" = 0;
+            "general.autoScroll" = true;
+            "general.smoothScroll" = true;
+            "mail.default_send_format" = 0;
+            "mail.tabs.drawInTitlebar" =
+              if config.nixfiles.modules.kde.enable
+              then 1
+              else 0;
+            "mailnews.start_page.url" = "about:blank";
+            "media.autoplay.blocking_policy" = 2;
+            "media.autoplay.default" = 5;
+            "media.autoplay.enabled" = false;
+            "media.hardwaremediakeys.enabled" = false;
+            "network.cookie.cookieBehavior" = 2;
+            "places.history.enabled" = false;
+            "reader.parse-on-load.enabled" = false;
+            "toolkit.legacyUserProfileCustomizations.stylesheets" = true;
+          };
+        };
+      };
     };
 
     boot = {

Consider giving Nix/NixOS a try! <3