about summary refs log tree commit diff
path: root/modules/nixos/thunderbird.nix
diff options
context:
space:
mode:
authorAzat Bahawi <azat@bahawi.net>2023-11-04 16:52:03 +0300
committerAzat Bahawi <azat@bahawi.net>2023-11-04 16:52:03 +0300
commit5da01d688fcfd4d1956197f7b7f9372e88687d05 (patch)
tree662647084b947301db091928c58f83ad74dbd232 /modules/nixos/thunderbird.nix
parent2023-10-30 (diff)
2023-11-04
Diffstat (limited to '')
-rw-r--r--modules/nixos/thunderbird.nix53
1 files changed, 53 insertions, 0 deletions
diff --git a/modules/nixos/thunderbird.nix b/modules/nixos/thunderbird.nix
new file mode 100644
index 0000000..5afb163
--- /dev/null
+++ b/modules/nixos/thunderbird.nix
@@ -0,0 +1,53 @@
+{
+  config,
+  lib,
+  ...
+}:
+with lib; let
+  cfg = config.nixfiles.modules.thunderbird;
+in {
+  options.nixfiles.modules.thunderbird.enable = mkEnableOption "Thunderbird";
+
+  config = mkIf cfg.enable {
+    nixfiles.modules.common.xdg.defaultApplications.thunderbird = [
+      "message/rfc822"
+      "x-scheme-handler/mailto"
+    ];
+
+    hm = {
+      programs.thunderbird = {
+        enable = true;
+        profiles.default = {
+          isDefault = true;
+          withExternalGnupg = true;
+        };
+        settings = {
+          "app.update.auto" = false;
+          "browser.display.document_color_use" = 2;
+          "browser.display.use_system_colors" = true;
+          "browser.search.region" = "US";
+          "browser.search.update" = false;
+          "datareporting.healthreport.uploadEnabled" = false;
+          "full-screen-api.warning.delay" = 0;
+          "full-screen-api.warning.timeout" = 0;
+          "general.autoScroll" = true;
+          "general.smoothScroll" = true;
+          "mail.default_send_format" = 0;
+          "mail.tabs.drawInTitlebar" =
+            if config.nixfiles.modules.kde.enable
+            then 1
+            else 0;
+          "mailnews.start_page.url" = "about:blank";
+          "media.autoplay.blocking_policy" = 2;
+          "media.autoplay.default" = 5;
+          "media.autoplay.enabled" = false;
+          "media.hardwaremediakeys.enabled" = false;
+          "network.cookie.cookieBehavior" = 2;
+          "places.history.enabled" = false;
+          "reader.parse-on-load.enabled" = false;
+          "toolkit.legacyUserProfileCustomizations.stylesheets" = true;
+        };
+      };
+    };
+  };
+}

Consider giving Nix/NixOS a try! <3