about summary refs log tree commit diff
path: root/modules/nixos/thunderbird.nix
diff options
context:
space:
mode:
authorAzat Bahawi <azat@bahawi.net>2023-11-05 18:10:26 +0300
committerAzat Bahawi <azat@bahawi.net>2023-11-05 18:10:26 +0300
commit647ea0667423ced895e4bcdd73a9401b1fe3ee69 (patch)
tree700db0911e1e2193bf07e8e756910378b4f8d4eb /modules/nixos/thunderbird.nix
parent2023-11-04 (diff)
2023-11-05
Diffstat (limited to '')
-rw-r--r--modules/nixos/thunderbird.nix64
1 files changed, 31 insertions, 33 deletions
diff --git a/modules/nixos/thunderbird.nix b/modules/nixos/thunderbird.nix
index 5afb163..2261dcd 100644
--- a/modules/nixos/thunderbird.nix
+++ b/modules/nixos/thunderbird.nix
@@ -14,39 +14,37 @@ in {
       "x-scheme-handler/mailto"
     ];
 
-    hm = {
-      programs.thunderbird = {
-        enable = true;
-        profiles.default = {
-          isDefault = true;
-          withExternalGnupg = true;
-        };
-        settings = {
-          "app.update.auto" = false;
-          "browser.display.document_color_use" = 2;
-          "browser.display.use_system_colors" = true;
-          "browser.search.region" = "US";
-          "browser.search.update" = false;
-          "datareporting.healthreport.uploadEnabled" = false;
-          "full-screen-api.warning.delay" = 0;
-          "full-screen-api.warning.timeout" = 0;
-          "general.autoScroll" = true;
-          "general.smoothScroll" = true;
-          "mail.default_send_format" = 0;
-          "mail.tabs.drawInTitlebar" =
-            if config.nixfiles.modules.kde.enable
-            then 1
-            else 0;
-          "mailnews.start_page.url" = "about:blank";
-          "media.autoplay.blocking_policy" = 2;
-          "media.autoplay.default" = 5;
-          "media.autoplay.enabled" = false;
-          "media.hardwaremediakeys.enabled" = false;
-          "network.cookie.cookieBehavior" = 2;
-          "places.history.enabled" = false;
-          "reader.parse-on-load.enabled" = false;
-          "toolkit.legacyUserProfileCustomizations.stylesheets" = true;
-        };
+    hm.programs.thunderbird = {
+      enable = true;
+      profiles.default = {
+        isDefault = true;
+        withExternalGnupg = true;
+      };
+      settings = {
+        "app.update.auto" = false;
+        "browser.display.document_color_use" = 2;
+        "browser.display.use_system_colors" = true;
+        "browser.search.region" = "US";
+        "browser.search.update" = false;
+        "datareporting.healthreport.uploadEnabled" = false;
+        "full-screen-api.warning.delay" = 0;
+        "full-screen-api.warning.timeout" = 0;
+        "general.autoScroll" = true;
+        "general.smoothScroll" = true;
+        "mail.default_send_format" = 0;
+        "mail.tabs.drawInTitlebar" =
+          if config.nixfiles.modules.kde.enable
+          then 1
+          else 0;
+        "mailnews.start_page.url" = "about:blank";
+        "media.autoplay.blocking_policy" = 2;
+        "media.autoplay.default" = 5;
+        "media.autoplay.enabled" = false;
+        "media.hardwaremediakeys.enabled" = false;
+        "network.cookie.cookieBehavior" = 2;
+        "places.history.enabled" = false;
+        "reader.parse-on-load.enabled" = false;
+        "toolkit.legacyUserProfileCustomizations.stylesheets" = true;
       };
     };
   };

Consider giving Nix/NixOS a try! <3