about summary refs log tree commit diff
path: root/modules/nixos/wayland.nix
diff options
context:
space:
mode:
authorAzat Bahawi <azat@bahawi.net>2024-03-04 14:54:25 +0300
committerAzat Bahawi <azat@bahawi.net>2024-03-04 14:54:25 +0300
commit037ef27243eab47d6e1c29f231c248dc2aa4966e (patch)
tree6a0ea8242df5c1d3b02a5a2b33d5aae44bd57855 /modules/nixos/wayland.nix
parent2024-03-03 (diff)
2024-03-04
Diffstat (limited to '')
-rw-r--r--modules/nixos/wayland.nix8
1 files changed, 2 insertions, 6 deletions
diff --git a/modules/nixos/wayland.nix b/modules/nixos/wayland.nix
index 5068c25..b64ab32 100644
--- a/modules/nixos/wayland.nix
+++ b/modules/nixos/wayland.nix
@@ -1,6 +1,7 @@
 {
   config,
   lib,
+  pkgs,
   ...
 }:
 with lib; let
@@ -9,11 +10,6 @@ in {
   options.nixfiles.modules.wayland.enable = mkEnableOption "Wayland";
 
   config = mkIf cfg.enable {
-    assertions = [
-      {
-        assertion = !config.nixfiles.modules.x11.enable;
-        message = "Pick only one!";
-      }
-    ];
+    hm.home.packages = with pkgs; [wl-clipboard];
   };
 }

Consider giving Nix/NixOS a try! <3