about summary refs log tree commit diff
path: root/modules/password-store.nix
diff options
context:
space:
mode:
authorazahi <azat@bahawi.net>2025-02-17 02:21:56 +0300
committerazahi <azat@bahawi.net>2025-02-17 02:21:56 +0300
commit59180328cda59817d71cd58c8f48ead047375064 (patch)
tree2cdd7d1bfa309839ef624c19daf283f510aacf69 /modules/password-store.nix
parent2025-02-05 (diff)
2025-02-17
Diffstat (limited to '')
-rw-r--r--modules/password-store.nix7
1 files changed, 3 insertions, 4 deletions
diff --git a/modules/password-store.nix b/modules/password-store.nix
index 886afb6..d6358a7 100644
--- a/modules/password-store.nix
+++ b/modules/password-store.nix
@@ -4,15 +4,14 @@
   pkgs,
   ...
 }:
-with lib;
 let
   cfg = config.nixfiles.modules.password-store;
 in
 {
   options.nixfiles.modules.password-store.enable =
-    mkEnableOption "the standard UNIX password manager";
+    lib.mkEnableOption "the standard UNIX password manager";
 
-  config = mkIf cfg.enable {
+  config = lib.mkIf cfg.enable {
     hm.programs = {
       password-store = {
         enable = true;
@@ -27,7 +26,7 @@ in
         let
           completions = "${config.hm.programs.password-store.package}/share/bash-completion/completions";
         in
-        mkAfter ''
+        lib.mkAfter ''
           source ${completions}/pass-otp
           source ${completions}/pass
         '';

Consider giving Nix/NixOS a try! <3