about summary refs log tree commit diff
path: root/modules/postgresql.nix
diff options
context:
space:
mode:
authorAzat Bahawi <azat@bahawi.net>2024-05-05 14:28:31 +0300
committerAzat Bahawi <azat@bahawi.net>2024-05-05 14:28:31 +0300
commit389becf9700d3dee7f09073ce4d235fc7c30b5c8 (patch)
tree3db9d75bd5275614fc904184c97b3133f38bc3d0 /modules/postgresql.nix
parent2024-05-04 (diff)
2024-05-05
Diffstat (limited to '')
-rw-r--r--modules/postgresql.nix9
1 files changed, 9 insertions, 0 deletions
diff --git a/modules/postgresql.nix b/modules/postgresql.nix
index 5081340..f9ea64f 100644
--- a/modules/postgresql.nix
+++ b/modules/postgresql.nix
@@ -1,5 +1,6 @@
 {
   config,
+  inputs,
   lib,
   pkgs,
   this,
@@ -94,5 +95,13 @@ in
         \unset QUIET
       ''
     );
+
+    topology = {
+      nodes.${this.hostname}.services.postgresql = {
+        name = "PostgreSQL";
+        icon = "${inputs.homelab-svg-assets}/assets/postgresql.svg";
+        details.listen.text = "127.0.0.1:5432";
+      };
+    };
   };
 }

Consider giving Nix/NixOS a try! <3