about summary refs log tree commit diff
path: root/modules/prometheus.nix
diff options
context:
space:
mode:
authorAzat Bahawi <azat@bahawi.net>2024-05-05 14:28:31 +0300
committerAzat Bahawi <azat@bahawi.net>2024-05-05 14:28:31 +0300
commit389becf9700d3dee7f09073ce4d235fc7c30b5c8 (patch)
tree3db9d75bd5275614fc904184c97b3133f38bc3d0 /modules/prometheus.nix
parent2024-05-04 (diff)
2024-05-05
Diffstat (limited to '')
-rw-r--r--modules/prometheus.nix11
1 files changed, 11 insertions, 0 deletions
diff --git a/modules/prometheus.nix b/modules/prometheus.nix
index 9f28cd5..673f288 100644
--- a/modules/prometheus.nix
+++ b/modules/prometheus.nix
@@ -1,7 +1,9 @@
 {
   config,
+  inputs,
   lib,
   libNginx,
+  this,
   ...
 }:
 with lib;
@@ -49,5 +51,14 @@ in
         "--storage.tsdb.wal-compression"
       ];
     };
+
+    topology = with cfg; {
+      nodes.${this.hostname}.services.prometheus = {
+        name = "Prometheus";
+        icon = "${inputs.homelab-svg-assets}/assets/prometheus.svg";
+        info = domain;
+        details.listen.text = "127.0.0.1:${toString port}";
+      };
+    };
   };
 }

Consider giving Nix/NixOS a try! <3