about summary refs log tree commit diff
path: root/modules/sound.nix
diff options
context:
space:
mode:
authorazahi <azat@bahawi.net>2025-02-17 02:21:56 +0300
committerazahi <azat@bahawi.net>2025-02-17 02:21:56 +0300
commit59180328cda59817d71cd58c8f48ead047375064 (patch)
tree2cdd7d1bfa309839ef624c19daf283f510aacf69 /modules/sound.nix
parent2025-02-05 (diff)
2025-02-17
Diffstat (limited to '')
-rw-r--r--modules/sound.nix5
1 files changed, 2 insertions, 3 deletions
diff --git a/modules/sound.nix b/modules/sound.nix
index 49ca5bc..db15686 100644
--- a/modules/sound.nix
+++ b/modules/sound.nix
@@ -4,15 +4,14 @@
   this,
   ...
 }:
-with lib;
 let
   cfg = config.nixfiles.modules.sound;
 in
 {
-  options.nixfiles.modules.sound.enable = mkEnableOption "sound support";
+  options.nixfiles.modules.sound.enable = lib.mkEnableOption "sound support";
 
   config =
-    mkIf cfg.enable {
+    lib.mkIf cfg.enable {
       services.pipewire = {
         enable = true;
 

Consider giving Nix/NixOS a try! <3