about summary refs log tree commit diff
path: root/modules/vaultwarden.nix
diff options
context:
space:
mode:
authorAzat Bahawi <azat@bahawi.net>2024-05-05 14:28:31 +0300
committerAzat Bahawi <azat@bahawi.net>2024-05-05 14:28:31 +0300
commit389becf9700d3dee7f09073ce4d235fc7c30b5c8 (patch)
tree3db9d75bd5275614fc904184c97b3133f38bc3d0 /modules/vaultwarden.nix
parent2024-05-04 (diff)
2024-05-05
Diffstat (limited to '')
-rw-r--r--modules/vaultwarden.nix7
1 files changed, 7 insertions, 0 deletions
diff --git a/modules/vaultwarden.nix b/modules/vaultwarden.nix
index 2cacb6c..edce8e5 100644
--- a/modules/vaultwarden.nix
+++ b/modules/vaultwarden.nix
@@ -2,6 +2,7 @@
   config,
   inputs,
   lib,
+  this,
   ...
 }:
 with lib;
@@ -141,5 +142,11 @@ in
           };
         };
       };
+
+      topology = with cfg; {
+        nodes.${this.hostname}.services.vaultwarden = {
+          info = mkForce domain;
+        };
+      };
     };
 }

Consider giving Nix/NixOS a try! <3