about summary refs log tree commit diff
path: root/nixosConfigurations/default.nix
diff options
context:
space:
mode:
authorAzat Bahawi <azat@bahawi.net>2024-04-21 02:15:42 +0300
committerAzat Bahawi <azat@bahawi.net>2024-04-21 02:15:42 +0300
commite6ed60548397627bf10f561f9438201dbba0a36e (patch)
treef9a84c5957d2cc4fcd148065ee9365a0c851ae1c /nixosConfigurations/default.nix
parent2024-04-18 (diff)
2024-04-21
Diffstat (limited to '')
-rw-r--r--nixosConfigurations/default.nix36
1 files changed, 14 insertions, 22 deletions
diff --git a/nixosConfigurations/default.nix b/nixosConfigurations/default.nix
index 8ef5f33..b685eb7 100644
--- a/nixosConfigurations/default.nix
+++ b/nixosConfigurations/default.nix
@@ -7,37 +7,19 @@ let
       modules ? [ ],
       configuration ? ./${name},
       this ? my.configurations.${name},
-      extraSpecialArgs ? {
-        localUsername = my.username;
-        localHostname = this.hostname;
-      },
     }:
     nameValuePair name (nixosSystem {
       inherit (this) system;
       modules =
         modules
-        ++ attrValues inputs.self.modules
         ++ attrValues inputs.self.nixosModules
         ++ optional (configuration != null) (import configuration);
       specialArgs = {
         inherit inputs this;
         inherit (inputs.self) lib;
-      } // extraSpecialArgs;
+      };
     });
 
-  # mkIso = system: {
-  #   this = {
-  #     hostname = "iso";
-  #     inherit system;
-  #     isHeadless = false;
-  #     isHeadful = false;
-  #   };
-  #   configuration = ./iso;
-  #   modules = [
-  #     "${inputs.nixpkgs}/nixos/modules/installer/cd-dvd/installation-cd-minimal-new-kernel.nix"
-  #   ];
-  # };
-
   mkTest = this: {
     modules = with inputs; [
       "${nixpkgs}/nixos/modules/profiles/qemu-guest.nix"
@@ -47,9 +29,6 @@ let
   };
 in
 mapAttrs' mkConfiguration {
-  # iso-arm = mkIso "aarch64-linux";
-  # iso-x86 = mkIso "x86_64-linux";
-
   test-headless = mkTest {
     hostname = "test-headless";
     system = "x86_64-linux";
@@ -63,6 +42,19 @@ mapAttrs' mkConfiguration {
     isHeadful = true;
   };
 
+  iso = {
+    this = {
+      hostname = "iso";
+      system = "x86_64-linux";
+      isHeadless = false;
+      isHeadful = false;
+    };
+    configuration = ./iso;
+    modules = [
+      "${inputs.nixpkgs}/nixos/modules/installer/cd-dvd/installation-cd-minimal-new-kernel.nix"
+    ];
+  };
+
   eonwe.modules = with inputs; [
     nixos-hardware.nixosModules.common-cpu-amd
     nixos-hardware.nixosModules.common-cpu-amd-pstate

Consider giving Nix/NixOS a try! <3