about summary refs log tree commit diff
path: root/nixosConfigurations/eonwe/default.nix
diff options
context:
space:
mode:
authorAzat Bahawi <azat@bahawi.net>2023-02-02 00:49:21 +0300
committerAzat Bahawi <azat@bahawi.net>2023-02-02 00:49:21 +0300
commit89399796d0b91e7904ce67de04bd2f60f0d93b5b (patch)
tree06d47b2ccc861fe8188cdb96910e651802ae06cc /nixosConfigurations/eonwe/default.nix
parent2023-01-30 (diff)
2023-02-02
Diffstat (limited to '')
-rw-r--r--nixosConfigurations/eonwe/default.nix52
1 files changed, 48 insertions, 4 deletions
diff --git a/nixosConfigurations/eonwe/default.nix b/nixosConfigurations/eonwe/default.nix
index 8889120..19eb8b1 100644
--- a/nixosConfigurations/eonwe/default.nix
+++ b/nixosConfigurations/eonwe/default.nix
@@ -72,16 +72,60 @@ with lib; {
     initrd.kernelModules = ["nvme"];
   };
 
+  # Filesystem creation:
+  # ```
+  # mkfs.vfat -F 32 -l nixos-boot /dev/nvmeXnYpZ
+  #
+  # zpool create
+  # -o ashift=12
+  # -o autotrim=on
+  # -O acltype=posixacl
+  # -O xattr=sa
+  # -O compression=zstd
+  # -O atime=off
+  # -O relatime=off
+  # -O devices=off
+  # -O canmount=off
+  # -O mountpoint=none
+  # nixos
+  # /dev/nvmeXnYpZ
+  #
+  # zfs create
+  # nixos/root
+  #
+  # zfs create
+  # -o mountpoint=legacy
+  # -o relatime=on
+  # -o encryption=on
+  # -o keyformat=passphrase
+  # nixos/root/ark
+  #
+  # zfs create
+  # -o mountpoint=legacy
+  # nixos/root/nix
+  # ```
   fileSystems = {
     "/boot" = {
-      device = "/dev/disk/by-uuid/FF1E-9CFD";
+      device = "/dev/disk/by-uuid/1363-02E6";
       fsType = "vfat";
     };
 
     "/" = {
-      device = "/dev/disk/by-uuid/20276c1b-7e46-430b-b741-2f4aeb76bc51";
-      fsType = "xfs";
-      options = ["noatime"];
+      device = "none";
+      fsType = "tmpfs";
+      options = ["size=8G" "mode=755"];
+    };
+
+    "/ark" = {
+      device = "nixos/root/ark";
+      fsType = "zfs";
+      neededForBoot = true;
+    };
+
+    "/nix" = {
+      device = "nixos/root/nix";
+      fsType = "zfs";
+      neededForBoot = true;
     };
   };
 

Consider giving Nix/NixOS a try! <3