about summary refs log tree commit diff
path: root/nixosConfigurations/iso/default.nix
diff options
context:
space:
mode:
authorAzat Bahawi <azat@bahawi.net>2022-12-17 20:35:36 +0300
committerAzat Bahawi <azat@bahawi.net>2022-12-17 20:35:36 +0300
commit313e18cb6119d4b03580d8d34fbec0c78bca872c (patch)
tree7d3f9583af9422c80fe20ae1dd1747e6b2c9b9a5 /nixosConfigurations/iso/default.nix
parent2022-12-17 (diff)
2022-12-17
Diffstat (limited to '')
-rw-r--r--nixosConfigurations/iso/default.nix27
1 files changed, 27 insertions, 0 deletions
diff --git a/nixosConfigurations/iso/default.nix b/nixosConfigurations/iso/default.nix
new file mode 100644
index 0000000..e435d0b
--- /dev/null
+++ b/nixosConfigurations/iso/default.nix
@@ -0,0 +1,27 @@
+{
+  lib,
+  pkgs,
+  ...
+}:
+with lib; {
+  secrets = mkForce {};
+
+  nixfiles.modules = {
+    git.client.enable = true;
+    openssh = {
+      client.enable = true;
+      server = {
+        enable = true;
+        port = 22;
+      };
+    };
+  };
+
+  programs.mtr.enable = true;
+
+  services.getty.autologinUser = mkForce my.username;
+
+  environment.noXlibs = false;
+
+  nixpkgs.config.allowBroken = true;
+}

Consider giving Nix/NixOS a try! <3