about summary refs log tree commit diff
path: root/nixosConfigurations/yavanna/default.nix
diff options
context:
space:
mode:
authorAzat Bahawi <azat@bahawi.net>2023-05-02 01:27:41 +0300
committerAzat Bahawi <azat@bahawi.net>2023-05-02 01:27:41 +0300
commit1e9d5f05b350cec8568b6c2eb4fb4d124e73e926 (patch)
tree1ae63982779fef6b367dc8dc4777a1ab89cab7f2 /nixosConfigurations/yavanna/default.nix
parent2023-04-14 (diff)
2023-05-02
Diffstat (limited to '')
-rw-r--r--nixosConfigurations/yavanna/default.nix31
1 files changed, 6 insertions, 25 deletions
diff --git a/nixosConfigurations/yavanna/default.nix b/nixosConfigurations/yavanna/default.nix
index 908b6d3..ba298f8 100644
--- a/nixosConfigurations/yavanna/default.nix
+++ b/nixosConfigurations/yavanna/default.nix
@@ -14,38 +14,19 @@ with lib; {
     # ipfs.enable = true;
   };
 
-  boot = {
-    loader.grub = {
-      enable = true;
-      device = "/dev/sda";
-    };
-
-    # NOTE This is probably not required, but I cannot test this out without
-    # risking "bricking" my VPS because Kimsufi/OVH doesn't provide a console
-    # access. This configuration was generated via nixos-infect[1] and at the
-    # time I didn't bother to test for loaded kernel modules and just left the
-    # automatically (IIRC) generated `hardware-configuration.nix' as is.
-    #
-    # There's, however, no indication that any NVME drives are being used and,
-    # as the matter of fact, the VPS itself is on KVM, so... I'm still not going
-    # to risk it, though.
-    #
-    # [1]: https://github.com/elitak/nixos-infect
-    initrd.availableKernelModules = ["nvme"];
+  boot.loader.grub = {
+    enable = true;
+    device = "/dev/sda";
+    configurationLimit = 5;
   };
 
   fileSystems."/" = {
-    device = "/dev/sda1";
+    device = "/dev/sda2";
     fsType = "ext4";
     options = ["noatime"];
   };
 
-  swapDevices = [
-    {
-      device = "/swapfile";
-      size = 4 * 1024;
-    }
-  ];
+  swapDevices = [{device = "/dev/sda3";}];
 
   zramSwap = {
     enable = true;

Consider giving Nix/NixOS a try! <3