about summary refs log tree commit diff
path: root/overlays.nix
diff options
context:
space:
mode:
authorAzat Bahawi <azat@bahawi.net>2024-07-10 14:02:06 +0300
committerAzat Bahawi <azat@bahawi.net>2024-07-10 14:02:06 +0300
commita88092202ccfdb981c6aef3270bdef20e7530f5f (patch)
treef6f2f82e7575aeead163bcf0c93bab494e7e70ce /overlays.nix
parent2024-06-29 (diff)
2024-07-10
Diffstat (limited to '')
-rw-r--r--overlays.nix16
1 files changed, 3 insertions, 13 deletions
diff --git a/overlays.nix b/overlays.nix
index 5b80ae2..d387ea3 100644
--- a/overlays.nix
+++ b/overlays.nix
@@ -1,4 +1,4 @@
-{
+_: {
   default = final: prev: {
     bruh = prev.callPackage ./packages/bruh.nix { };
 
@@ -39,12 +39,12 @@
       _: super: {
         pname = "logcli";
         subPackages = [ "cmd/logcli" ];
-        nativeBuildInputs = super.nativeBuildInputs ++ [ final.installShellFiles ];
+        nativeBuildInputs = (super.nativeBuildInputs or [ ]) ++ [ final.installShellFiles ];
         postInstall =
           (super.postInstall or "")
           + ''
             installShellCompletion --cmd logcli \
-              --bash <($out/bin/logcli --completion--script-bash) \
+              --bash <($out/bin/logcli --completion-script-bash) \
               --zsh <($out/bin/logcli --completion-script-zsh)
           '';
         preFixup = null;
@@ -61,16 +61,6 @@
 
     parinfer-rust = prev.callPackage ./packages/parinfer-rust.nix { };
 
-    prismlauncher-unwrapped =
-      (prev.prismlauncher-unwrapped.override (finalAttrs: {
-        stdenv = final.useMoldLinker finalAttrs.stdenv;
-      })).overrideAttrs
-        (
-          _: super: {
-            patches = (super.patches or [ ]) ++ [ ./patches/prismlauncher-allow-offline-accounts.patch ];
-          }
-        );
-
     telegram-desktop =
       (prev.telegram-desktop.override (finalAttrs: {
         stdenv = final.useMoldLinker finalAttrs.stdenv;

Consider giving Nix/NixOS a try! <3