about summary refs log tree commit diff
path: root/packages/myip.nix
diff options
context:
space:
mode:
authorAzat Bahawi <azat@bahawi.net>2023-09-30 15:21:49 +0300
committerAzat Bahawi <azat@bahawi.net>2023-09-30 15:21:49 +0300
commit0221d5913ea26fde9493dadfbb265f2ff103124f (patch)
tree29258145f96ffd9bcf5e39f6a1e1e7c4cab57355 /packages/myip.nix
parent2023-09-28 (diff)
2023-09-30
Diffstat (limited to '')
-rw-r--r--packages/myip.nix10
1 files changed, 10 insertions, 0 deletions
diff --git a/packages/myip.nix b/packages/myip.nix
index a830139..67ea1ed 100644
--- a/packages/myip.nix
+++ b/packages/myip.nix
@@ -1,12 +1,22 @@
 {
   dnsutils,
+  lib,
   writeShellApplication,
 }:
 writeShellApplication {
   name = "myip";
+
   runtimeInputs = [dnsutils];
+
   text = ''
     dig -4 +short @resolver1.opendns.com myip.opendns.com A
     dig -6 +short @resolver1.opendns.com myip.opendns.com AAAA
   '';
+
+  meta = with lib; {
+    description = "A dumb tool to get host's current public IP";
+    homepage = "https://git.azahi.cc/nixfiles";
+    license = licenses.wtfpl;
+    maintainers = with maintainers; [azahi];
+  };
 }

Consider giving Nix/NixOS a try! <3