about summary refs log tree commit diff
path: root/packages/nixfiles.nix
diff options
context:
space:
mode:
authorAzat Bahawi <azat@bahawi.net>2024-03-31 21:29:27 +0300
committerAzat Bahawi <azat@bahawi.net>2024-03-31 21:29:27 +0300
commit9a5427e3a0c0ccf2a82dc503149a26b23fbd6004 (patch)
treef28beec29deeea36038615a8fb98a810891940b5 /packages/nixfiles.nix
parent2024-03-19 (diff)
2024-03-31
Diffstat (limited to '')
-rw-r--r--packages/nixfiles.nix46
1 files changed, 24 insertions, 22 deletions
diff --git a/packages/nixfiles.nix b/packages/nixfiles.nix
index 286214c..9bb3ea6 100644
--- a/packages/nixfiles.nix
+++ b/packages/nixfiles.nix
@@ -10,19 +10,18 @@
   writeShellApplication,
   writeTextDir,
   xdg-utils,
-}: let
+}:
+let
   bin = writeShellApplication {
     name = "nixfiles";
 
-    runtimeInputs =
-      [
-        git
-        jq
-        nix
-        nvd
-        openssh
-      ]
-      ++ lib.optional stdenv.isLinux xdg-utils;
+    runtimeInputs = [
+      git
+      jq
+      nix
+      nvd
+      openssh
+    ] ++ lib.optional stdenv.isLinux xdg-utils;
 
     # Shamelessly appropriated from https://github.com/ncfavier/config.
     # Hopefully Naïm will not sue me for copyright infrigment.
@@ -180,17 +179,20 @@
     complete -F _nixfiles nixfiles
   '';
 in
-  symlinkJoin {
-    name = "nixfiles";
+symlinkJoin {
+  name = "nixfiles";
 
-    paths = [bin bashCompletion];
+  paths = [
+    bin
+    bashCompletion
+  ];
 
-    meta = with lib; {
-      description = "A helper utility to manage NixOS configurations with Nix flakes";
-      homepage = "https://git.azahi.cc/nixfiles";
-      license = licenses.wtfpl;
-      platforms = platforms.unix;
-      maintainers = with maintainers; [azahi];
-      mainProgram = "nixfiles";
-    };
-  }
+  meta = with lib; {
+    description = "A helper utility to manage NixOS configurations with Nix flakes";
+    homepage = "https://git.azahi.cc/nixfiles";
+    license = licenses.wtfpl;
+    platforms = platforms.unix;
+    maintainers = with maintainers; [ azahi ];
+    mainProgram = "nixfiles";
+  };
+}

Consider giving Nix/NixOS a try! <3