about summary refs log tree commit diff
path: root/packages/openssl_1_0_0.nix
diff options
context:
space:
mode:
authorAzat Bahawi <azat@bahawi.net>2023-10-13 20:39:39 +0300
committerAzat Bahawi <azat@bahawi.net>2023-10-13 20:39:39 +0300
commit8207b0e249513feffd163d4228de685530fc665b (patch)
treec3b9e26b0b4f49873b2fc70bfc7f3b4a8a65f8bb /packages/openssl_1_0_0.nix
parent2023-09-30 (diff)
2023-10-13
Diffstat (limited to '')
-rw-r--r--packages/openssl_1_0_0.nix39
1 files changed, 39 insertions, 0 deletions
diff --git a/packages/openssl_1_0_0.nix b/packages/openssl_1_0_0.nix
new file mode 100644
index 0000000..b1572d1
--- /dev/null
+++ b/packages/openssl_1_0_0.nix
@@ -0,0 +1,39 @@
+{
+  autoPatchelfHook,
+  fetchurl,
+  lib,
+  stdenvNoCC,
+}:
+stdenvNoCC.mkDerivation (finalAttrs: {
+  pname = "openssl";
+  version = "1.0.0";
+
+  src = fetchurl {
+    url = "https://downloads.dotslashplay.it/resources/openssl/openssl_${finalAttrs.version}.tar.xz";
+    sha256 = "sha256-B8/FdkheAwrAtscn6dvUuen1slfRglM/kJb2xGm7uvA=";
+  };
+  sourceRoot = "x86_64";
+
+  nativeBuildInputs = [autoPatchelfHook];
+
+  dontPatch = true;
+  dontConfigure = true;
+  dontBuild = true;
+
+  installPhase = ''
+    runHook preInstall
+
+    install -Dm555 -t $out/lib libcrypto.so.1.0.0
+    install -Dm555 -t $out/lib libssl.so.1.0.0
+
+    runHook postInstall
+  '';
+
+  meta = with lib; {
+    description = "Ancient OpenSSL version that some GOG games require";
+    homepage = "https://downloads.dotslashplay.it/resources/openssl";
+    license = licenses.asl20;
+    sourceProvenance = with lib.sourceTypes; [binaryBytecode];
+    maintainers = with maintainers; [azahi];
+  };
+})

Consider giving Nix/NixOS a try! <3