about summary refs log tree commit diff
path: root/packages/ultimmc.nix
diff options
context:
space:
mode:
authorAzat Bahawi <azat@bahawi.net>2022-09-13 02:37:13 +0300
committerAzat Bahawi <azat@bahawi.net>2022-09-13 02:37:13 +0300
commitcc1ed99b3ec1cb8d025c11bc4db45bf643ef3780 (patch)
tree548b31332a279a9aae00c202be5623d74e698ad7 /packages/ultimmc.nix
parent2022-09-12 (diff)
2022-09-13
Diffstat (limited to '')
-rw-r--r--packages/ultimmc.nix22
1 files changed, 7 insertions, 15 deletions
diff --git a/packages/ultimmc.nix b/packages/ultimmc.nix
index 86377b4..0259a7a 100644
--- a/packages/ultimmc.nix
+++ b/packages/ultimmc.nix
@@ -16,22 +16,14 @@ stdenv.mkDerivation rec {
   src = fetchFromGitHub {
     owner = "UltimMC";
     repo = "Launcher";
-    rev = "6bfa07e728865d8d31a43ef5231b2461d55fc4b3";
+    rev = "a522ec3ad4602de1f457a25bce98ef912a29d7d6";
     fetchSubmodules = true;
-    hash = "sha256-gMEjy1jM/T7Un4FDNbAd9AAdVUOHRfL+arhahHPCBFo=";
+    hash = "sha256-+UgBblyEx0cKH8UMBOPtjhQLv2YUKj91UokQWKCEPbY=";
   };
 
-  nativeBuildInputs = [
-    cmake
-    jdk
-    ninja
-    wrapQtAppsHook
-  ];
+  nativeBuildInputs = [cmake jdk ninja wrapQtAppsHook];
 
-  buildInputs = [
-    qtbase
-    zlib
-  ];
+  buildInputs = [qtbase zlib];
 
   postPatch = ''
     substituteInPlace CMakeLists.txt \
@@ -44,7 +36,7 @@ stdenv.mkDerivation rec {
 
   desktopItem = makeDesktopItem {
     name = pname;
-    exec = "DevLauncher";
+    exec = pname;
     icon = pname;
     desktopName = pname;
     genericName = "Custom Minecraft launcher";
@@ -54,7 +46,7 @@ stdenv.mkDerivation rec {
   dontWrapQtApps = true;
 
   postInstall = ''
-    rm $out/DevLauncher
+    rm $out/${pname}
 
     install -Dm644 \
       ${desktopItem}/share/applications/${pname}.desktop \
@@ -65,7 +57,7 @@ stdenv.mkDerivation rec {
   '';
 
   postFixup = ''
-    wrapProgram $out/bin/DevLauncher \
+    wrapProgram $out/bin/${pname} \
       --add-flags "--dir \''${XDG_DATA_HOME:-~/.local/share}/${pname}" \
       "''${qtWrapperArgs[@]}"
   '';

Consider giving Nix/NixOS a try! <3