about summary refs log tree commit diff
path: root/checks.nix
diff options
context:
space:
mode:
Diffstat (limited to '')
-rw-r--r--checks.nix26
1 files changed, 7 insertions, 19 deletions
diff --git a/checks.nix b/checks.nix
index f9949e3..1bb454c 100644
--- a/checks.nix
+++ b/checks.nix
@@ -1,5 +1,4 @@
 { inputs, system }:
-with inputs.nixpkgs.lib;
 let
   pkgs = inputs.self.legacyPackages.${system};
 in
@@ -14,24 +13,6 @@ in
         enable = true;
         package = pkgs.nixfmt;
       };
-      deadnix = {
-        enable = true;
-        settings.edit = true;
-      };
-      editorconfig-checker.enable = true;
-      prettier = {
-        enable = true;
-        types_or = mkForce [ "css" ];
-      };
-      shellcheck.enable = true;
-      shfmt.enable = true;
-      statix.enable = true;
-      typos = {
-        enable = true;
-        types = [ "text" ];
-        pass_filenames = false;
-      };
-      yamllint.enable = true;
       promtool = {
         enable = true;
         name = "promtool";
@@ -39,6 +20,13 @@ in
         entry = "${pkgs.prometheus.cli}/bin/promtool check rules";
         files = "(?x)^(modules/nixos/monitoring/rules/.*\.yaml)$";
       };
+      deadnix.enable = true;
+      editorconfig-checker.enable = true;
+      prettier.enable = true;
+      shellcheck.enable = true;
+      shfmt.enable = true;
+      statix.enable = true;
+      yamllint.enable = true;
     };
   };
 }

Consider giving Nix/NixOS a try! <3