summaryrefslogtreecommitdiff
path: root/checks.nix
diff options
context:
space:
mode:
Diffstat (limited to 'checks.nix')
-rw-r--r--checks.nix8
1 files changed, 2 insertions, 6 deletions
diff --git a/checks.nix b/checks.nix
index a1915fa..86cb452 100644
--- a/checks.nix
+++ b/checks.nix
@@ -1,9 +1,5 @@
-{ inputs, system }:
-let
- pkgs = inputs.self.legacyPackages.${system};
-in
-{
- preCommit = inputs.pre-commit.lib.${system}.run {
+inputs: system: pkgs: {
+ preCommit = inputs.git-hooks.lib.${system}.run {
src = builtins.path {
name = "nixfiles";
path = ./.;